Control Hub Light Only Blinking Blue (After Around 20 Seconds)

Hi! My team and I are having issues with our REV Control Hub. We’ve been following the OnBot Java Guide provided by FIRST (, and we have been unable to progress because our Control Hub is unresponsive. Each time we power it on (connected to a Tetrix W39057 12V), our Control Hub’s light is solid blue for around 20 seconds, turns solid green for around two seconds, and begins blinking blue for however long we have it powered on past that. Due to this, we are unable to download the necessary apps to the Control Hub and we are also unable to connect it to the Driver Hub via the CH’s WiFi network.

How can we return the Control Hub back to its basic, stable state (with a stable green light that flashes blue once every 5 seconds)? Please explain in basic terms, as we are a new team with little knowledge on this topic.

EDIT: We have already tried to reset the CH’s WiFi to no avail. We have also tried connecting it to the Hardware Client, which does recognize it, but the CH is unresponsive and we are unable to download the aforementioned apps.

Control Hub troubleshooting details can be found here…

Control Hub Troubleshooting - DUO Control System

If, after reviewing that documentation you still have problems you should contact REV for further help.

There is a little reset button on the control hub, next to the RS485 port. The button only resets the Wifi though even though it claims it is a factory reset, so I’m not sure how helpful it is if the control hub has a more serious issue. I’d also try the REV hardware client, to see if the USB port responds even if Wifi will not.

Steps for Wifi reset taken from the help guide:

  • Unplug power
  • Press and hold the button, power on the control hub
  • You can release it after it flashes multiple colors

Sorry, but we tried both methods in our meeting today already and neither worked (really should have specified in the original post). Thanks anyways!

I think what is going on is its booting up fine, running for a few seconds (green light), then running into a serious flaw, weither that is electrical, android itself, or the FTC robot controller app.

I’m going to suggest a different debugging approach. First make sure that your power is fine (always good to check). If everything still is not working after unplugging everything else, after you try different power inputs, and after making sure there aren’t broken connectors, I’d move onto software problems.

Software side of things it is extremely unlikely that Android would be corrupt, unless a power issue happened at some time. If Android is fine, but the FTC Robot controller app (on the control hub) is not working, the USB-C port should still work. You can test this by plugging it in and seeing if the laptop has a pop-up about drivers, or if a flash drive presents itself.
There are methods to re-install the FTC Robot controller app if it is having problems, using Android studio and the USB port.

If both of those prove fruitless then it is time to call REV. Not the live help line, because they may give the exact same general advice that are above. They also may not have stock, considering the shortages.

Let me know if one of those things help.

Let’s approach this in a new direction.

  1. Have you connected the Control Hub to the computer via USB-C, and detected the device with the REV Hardware Client?

  2. How do you normally install software - are you a MacOS/Apple team and don’t have access to the hardware client, and thus must side load applications?

Something tells me you might be running into a permissions problem under the hood, and there’s something in the underlying Android OS asking for permissions. Android Studio and the REV Hardware Client can auto-approve permissions prompts, but a side loaded app cannot. If this is the case, you either need to get a Windows computer so you can run the REV Hardware Client or we’ll need to give you instructions on how to download and run a tool called “scrcpy” that can allow you to remotely view the Android interface under the hood and click on the hidden permissions pop-ups.

Let us know if this sounds like your situation. You can also look in your Robot Controller log file and look for “permission” messages with the word “denied” in it. That will be the clear indicator. Otherwise, permissions messages will have the word “Granted” instead.


Sorry, but we have been using a Windows computer and already have the Hardware Client installed, so your advice sadly does not apply. Thanks anyways.
Also, we have connected the Control Hub via USB-C, but that has done nothing to correct our issue, so we have determined it’s a faulty unit.

I presume you’ve updated the unit’s firmware, OS, and the Robot Controller software? Can you take a screenshot of the device once it is selected within the REV Hardware Client?

We’ve been unable to do that because of the connection issues mentioned in the initial post.

If you plug into the Control Hub via USB-C, you don’t need the device’s Wi-Fi network. You can communicate and configure the Control Hub directly with the REV Hardware Client. Do you have a problem doing that?

By “connection issues”, I meant both WiFi and USB-C (probably should have been clearer on that). So, yes we do have a problem with that.

So you mentioned that the Control Hub is recognized by the REV Hardware Client (RHC), can you provide a screenshot of what the RHC page looks like when you click on the device in the list? When you say it’s unresponsive, what do you do that it is unresponsive to?

If you’ve already contacted REV Support just let me know and I’ll stop trying to help. :slight_smile:

We’ve already reached out to REV.