Control Hub Stuck in Recovery Mode

We’re helping a team out at an event, and their Control Hub is stuck in recovery mode. When powering on, the REV Hardware client recognizes that the device is connected and presents the option for updating. However, attempting to update the device results in an error “premature end of stream, expected 1 more byte” and crashes the device into recovery mode. If the device is not updated, it will crash into recovery mode over time.

In the brief amount of time that it is reporting versions, the OS is 1.1.1 but the robot controller app version is unknown. The firmware is also reported as unknown and cannot be updated since the robot controller app is reported as out-of-date. Is there any way to recover it? Thanks in advance!

I actually ran into that same exact problem with a DragonBoard Control Hub (a Control Hub with a USB Mico port instead of USB-C port) the other day. I tried updating the Robot Controller software multiple times, and it always failed with the same error.

What I ended up doing was replace the USB cable, waited about 5 minutes after powering it on, and tried again. It worked, the software updated, except the Control hub never rebooted afterwards. I waited another 5 minutes, power cycled, and everything came up properly.

If that doesn’t work, try resetting the device.
(1) Power the control hub off
(2) Hold the reset button down
(3) while holding the reset button, power on the hub.
(4) while still holding the button, hold it until the light begins flashing different colors.
(5) release the reset button
(6) try installing software again.
(yes, I totally realize this is recovery mode, but going through this process might help you)

Good luck!

Thanks! We’ve swapped USB cables and computers, but haven’t had any success with being able to run an update in the hardware client. The reset button also doesn’t seem to be working when pressed down. Is there anything else we can try?

When the device is reportedly in recovery mode, is the LED blinking funky colors? As in its not the normal blue and green? I’m just wondering if the button might be stuck or damaged for some reason.