No roles have been assigned

Good Day Guys,

So, i’m trying to login to the ftc-ml homepage and it shows me this issue that currently no roles have been assigned to my FIRST account, although im already registered and the Lead/ Mentor of my team!
Any help with this manner. Did i miss anything?
Thanks in advance

I can see your dashboard account in FIRST’s internal systems, and see that you are associated with a team properly, but the FIRST dashboard is not communicating that association to ftc-scoring (which passes it on the ftc-ml) and that’s why you are seeing this message.

I apologize for the inconvenience while we work with IT to determine why this is happening.

1 Like

Thanks for the information. We are
However, do you know any other techniques we can use, in the meanwhile this issue will be solved from the IT side? Because, we are only 5 days away from the Tripoli Qualifications which we are participating in!
Anyways, I will try to find some other way out of this issue.

Again, thanks for the response, and im waiting for a feedback from your side about the communication issue.

Hello there! It looks like your team’s account needed additional processing, and so once we determined this we began the update process. Unfortunately this specific process involves a third-party system, and because of this the updates will likely take between 12-24 hours to be completely propagated everywhere. It is our hope that by this time tomorrow (but realistically sooner) you should be able to access the FTC-ML system properly. Let us know if you have any further issues tomorrow.

I apologize that we cannot fast-track this any more quickly.


Hello Danny,
No worries mate, in the meanwhile i will be reading all about the ftc-ml document anyways to foresee any obstacles that we might encounter.
Thank you very much for the quick update!

@malekbaitulmal The sync from the third party appears to have happened. You should be good to go.

hmmmm… now this is weird!.
I have received two emails from the 3rd party system. However, something else seems to be missing or so, since i still have the same issue with no roles have been assigned.
First Email: The FTC Registration Order

Are there any steps that i can do manually from my side?

The Second email!

The Pitsco invoice for $0.00 is to be expected. The bug in IT’s system for international teams seems to be that in some cases if a Pitsco order is not created, then your “ready to order” flag is not set, which means your registration is not complete. The workaround is to apparently generate a fake Pitsco order on the backend, which is what one of the internal FIRST staff did for you, and that updates the “ready to order” flag.

I now see you as associated properly with your teams when I hit the api endpoint that ftc-scoring does.

Can you ensure that you are logged out of both ftc-ml and ftc-scoring by clicking on your name in the upper right hand corner on, and then clicking on the red Logout button that should appear on the ftc-scoring profile page that that redirects you to? I’m wondering if there’s something cached from your last session.

And then re-login. If that doesn’t work, clear your cookies for If that doesn’t work, please post more screenshots here.

1 Like

It looks like its all good now and im just getting started on using the platform.
Thank you very much mate for the tremendous support. In the meanwhile i’ll keep you posted if anything new pops up.

1 Like


Hello! We are with the same issue for a Brazilian team this season. Could you do this fix for them as well?

Team #17728 - BrainMachine


Can you please try again? If it still doesn’t work, please send the email address you are using associated with the dashboard account of the person trying to access the tool to for further investigation.

Did not work. Asked them to send the email. Thank you anyway!