Red Screen Traceback (of Death)

Hello @crabigator,

Instead of sticking to the old thread I am taking the liberty of starting a new thread to fully understand the issue.

On my Ubuntu (21.10)/Firefox (v94) desktop, if I run into logon issues, I follow my interpretation of your advice and delete all FTC prefixed cookies. Everything works as expected for the ML work.

Unfortunately, the same approach does not work on three other machines:

  • Two Windows 10 machines with Chrome browser
  • One Google Pixel phone with Firefox browser

With ALL cookies deleted (not just FTC ones), I get the Red Screen Traceback. Refresh does not get rid of the traceback on any of these machines. For the smartphone I resort to reboot to make progress.

On the Windows 10 machines, if I logout and login again without flushing the cache I get the “HQ notified” message.

On the smartphone, the experience is inconsistent - it is mostly the red traceback but occasionally I’m able to get to the ML “home” screen.

The other minor issue is that the buttons on the modal dialog boxes require a second click for the first time selection in the Ubuntu/Firefox configuration. This is consistent across all dialog boxes indicating some kind of browser issue.

This issue with my account. I have not been able to get the second person (only two “administrators” for the team presently) try these operations. The earliest I can get this person to assist is next Tuesday. Therefore, I would welcome your suggestions on any workarounds for the Windows 10 platform (which is the only platform for team demonstrations/activities).

On the Windows 10 platform, I:

  • Navigate to
  • Enter my credentials (that appear to be accepted)
  • Encounter red traceback
  • Refresh does not eliminate the red traceback

Kind regards.


Kind regards.

I’m going to ignore the phone for now as we really don’t expect people to use a phone with ftc-ml and we’ve done no internal testing with ftc-ml on mobile. However, consistent failure on a Windows 10 machine is certainly problematic.

Some questions:

  • If you use Firefox latest on the Windows 10 machine do you see the same red stacktrace?
  • Are the Windows 10 machines on the same network as your Ubuntu machine?
  • What sort of firewall settings do you have on the Windows 10 machine?
  • Is it a machine supplied by a school district? If so, does it have software that proxies network traffic?
  • If you login with the failing Windows 10 machine from a different network (coffee shop wifi, friend’s wifi) does it still fail?
  • If you login with a different Windows 10 machine, if you have access to one, does it also fail?

On the Windows 10 machine can you hit F12, navigate to the network tab, attempt a login, capture the failure, and then Private Message me a screenshot of the network traffic?

You can Private Message someone by clicking on their avatar and clicking the blue Message button.

Thank you.

Hello @crabigator,

The earliest I will be able to get back to you in response to your suggestions regarding the Windows 10 machine is Tuesday.

Just some quick answers for now:

  • The school’s machines are Windows with School recommendation for the students to use Chrome. (will check version on Tuesday)
  • The classroom desktop had the issue as well as two students’ notebooks (school supplied OS image)
  • The Ubuntu machine is my personal desktop at home. After doing what you asked me to do earlier, I am able to get back on track by following your suggestions for recovery. (Unfortunately, I do not have access to a personal notebook). Do not worry about the Ubuntu machine except for the “second” click with the browser, if at all that is worth pursuing right now. It is definitely not a showstopper.
  • I will talk to to the lone IT Administrator in School to get some high level details on the network.
  • I will try the failing Windows 10 machine by asking the Team Lead Youth Member to try the exercise at home.
  • I mentioned the phone only to indicate that the School’s LAN experienced the same problem as my cellular provider (Verizon); I was using it simply to overcome the time constraint hurdle on Saturday afternoon. It experienced the same failure as the School’s machines did.

These machines are in a private school (no ISD procurement). I will send further details late Tuesday evening. Thanks.

Kind regards.

Hello @crabigator,

Two persons (One Team Admin, One Youth Member) successfully logged on to ftc-ml site from their respective home networks. Subsequently, the Youth Member logged on to the site from the school network (after clearing the browser cache as a routine step). The logon issues have subsided except when the cache is not cleared and the user is switching between FTC sites.

The Red Screen Traceback may be attributable to the school’s network. (Although that still begs the question why I experienced it with a cellular data connection but this is simply a red herring and no further attempts will be made to connect to the sites using a smartphone). I had requested a discussion with the school’s IT administrator several times even before this issue arose. Even yesterday, I could not speak to the person for reasons unknown to me but we were working during after-school hours. Asking for permission to use point-to-point packet capture (the last time I used Microsoft Network Monitor the version number was 3.x - I have no idea what it is currently) is impractical.

There is something going in the school’s network that I would prefer not to interfere with or even pretend to understand - audit, PenTest, etc.

There is an inherent problem for a first time user to logon to ftc-ml from the school’s network which comprises 5+ SSIDs and no noticeable RJ-45 jacks. The Youth Member notebooks use a “student” SSID while the lab desktop uses another SSID and both had the common issue. A second Youth Member had the same issue and our suggestion to that person was to repeat the attempt from the home network and to let us know.

Since we have a satisfactory workaround (and it is beyond my scope to work with the school’s sole IT admin person), please consider the issue resolved/closed unless there is something basic that you would like the Team (Admins or Youth Members) to test. Thanks again for your understanding and helping us to overcome the hurdle.

The Youth Members are very happy for the opportunity to participate in the beta. Like everyone else, they wish that the budget was more elastic.

Kind regards.