Video Delete Not Working

When I Imported the videos a couple were too big, I tried selecting the videos and deleting but when I hit the Delete video button nothing happened.

Understand that when you upload videos, the system processes the frames of the video automatically. That process cannot be interrupted. If you uploaded a massive video, you have to wait for that process to complete before you can delete the video (be very mindful of every action you take).

I deleted the videos from your workspace that were over the 1000 frame limit.


Thanks, How did you delete them?

I made myself an Administrator for your team (the exact same as your Lead Coach status) and I clicked on each red video in the list and pressed “Delete Video”. It’s likely when you tried to delete the videos one or more of the videos could not be deleted because there was still too many pending or in-work actions in the back-end. In order to prevent a rogue team/bug from bringing the whole system to a halt, we limit the number of simultaneous actions any team can have processing at once. Unfortunately you had to wait until everything had finished processing, even though you have no way of knowing when that happens - showing/sharing status across multiple application instances is hard and we decided not to (sorry!).


1 Like