Video frames not extracting

When I use the First Machine learning toolchain I upload my video but the frames do not start extracting. I have been waiting for it for around an hour.

Update: I uploaded a different video and it started extracting fine. Probably something wrong with how we combined our videos.

If you see a red background, it means the video failed to load and be processed by the engine. If you’re authoring your own videos, make sure you’re using a “commonly” used MP4 codec, like H.264 otherwise the engine we’re using may not understand the codec you’re using to know how to break it up into frames.


We are using built in windows software to record our footage. We did a small 30 second clip and it worked; however, using the same settings we recorded a longer ~100 second clip and it didn’t work. We even tried using FFMPEG in order to switch its mp4 codec explicitly to H.264 and it still didn’t work. What are we missing?

30 seconds isn’t “small”, it’s “huge” - 30 seconds at 30 fps is 900 frames, and when you’ve got to manage those frames manually that’s not realistic.

The ftc-ml site is open source, here’s the file that sets the limits:

You can see you have a maximum frames limit, max video length, video size, etc… I bet your video is exceeding one of those limits.


Ok, Thanks that was helpful