Control Hub Trouble (Solid Blue Light). Please help!

Please help as we are out of options!

Summary of problem:
*We have a consistent blue LED light on our control hub that was previously working fine. We get one single flash and then nothing else
*Control Hub will not go through any resets. When we try to go through the steps with the reset button, we never see any new colors on the LED.
*When we plug into Rev Hardware Client through USB-C, we are very limited as to available actions. The Robot Controller App seems to consistently be connecting and disconnecting. As a result, we are not able to update/downgrade our Expansion/Control Hub Firmware nor our Control Hub Operating Software. It will pop up with options for a second, but is not capable of installing anything.
*We have been working with Rev’s awesome tech support team all day but they are out of ideas for helping us.

I have included a screenshot for what we are seeing in the Hardware Client.

Thank you so much for any advice!

Did you send any logs to REV?

If not they might give a clue. Select the Utilities tab and you should be able to grab logs. Send them to REV and/or post them here.

Yes, they got all of our logs today. They are thinking it is something with the Robot Controller App, which is unfortunately outside of their expertise.

Here are some additional screenshots that I could not include in the original post

This will only pop up for a second after pressing “Start App” and it will not allow to successfully install/re-install or downgrade anything other than the Robot Controller App. We tried a few different versions of the Robot Controller App and it did not help.

Hey there!

My “hail Mary” in times like this is to download and use the scrcpy tool. If you plug into the Control Hub via USB-C, scrcpy will route the display and mouse controls from the android OS on the Control hub to your laptop. That way you can interact with the Android subsystem of the control hub and manually Uninstall the RC app from the device, and then reinstall it via the REV Hardware Client (it needs to be done by the hardware client because the hardware client can automatically respond to permissions requests required by first time installs versus upgrades).

You might also want to just run the RC app on the Control hub with scrcpy running to see what the control hub is doing under the covers, it might be popping up messages that you just can’t see.

You can get scrcpy from here:


Hi Danny!

Thanks so much for the suggestions. So I was able to successfully download and run scrcpy. I tried deleted the RC app, and re-installing it through the Hardware Client, and it doesn’t seem to be helping. I tried it first with version 8.0, since 8.1.1 seems to possibly be the source of our issues, but no version of the RC app that I have tried seems to be different. I tried doing it twice just to be sure. I still am seeing a constant blue light and the reset will still not work either.

I will share some screenshots of what I am seeing. Also, sometimes in Rev Hardware Client I see an error pop up that says “socket hang up”. I was seeing this frequently early yesterday, but then it went away for awhile and now the error seems consistently back again.

Should I also be deleting the FtcAccess-PointService? I did not previously because I was unsure

No, only delete the RC App from the Control Hub. If you delete the FtcAccess-PointService or any other app you’ll need to reinstall the Control Hub OS to restore it (that service is part of the Control Hub OS component).

From talking with REV support, there are a number of signs that may point towards file system corruption. If you check your log files, there are probably messages about blocks files being corrupted, and your inability to run the RC app no matter which version you’ve installed seems to point to this.

By the way, the blue LED on the Control Hub is actually controlled by the RC App itself; the blue LED is on by default which you’ll see it on while the device is powering/booting. Then when the RC app loads it causes the LED to blink blue while things are being initialized. Finally the RC app causes the LED to turn Green when everything is ready. Everything you’re describing with the LED and the inability to launch the RC app (and keep it launched) jives with each other.

Also when the app crashes, all communication sockets are then lost with it, so it makes sense that you’re getting socket errors. The only question is why the RC app keeps crashing regardless of which version is installed (and re-installed). Corrupted installation that isn’t being cleaned up properly and/or corrupted file system is the easy thing to blame, but it’s impossible to tell if it’s a red herring or not. Two systems being corrupted by being updated seems far fetched, but two systems being corrupted by the same computer/setup because of possibly a bad cable/connection or faulty software download (that somehow passed the checksum) is more likely, but definitely there’s no smoking gun that we can identify. Ugh, this is a nail biter.

I haven’t checked with REV, but I wonder what a factory reset does on the Control Hub. That’s when you use scrcpy to access the Control Hub, go to the settings menu, go to “Storage and Reset”, and reset to factory default. I hooked a monitor up to my HDMI output on the Control Hub so I could always see the display on the device, and I also plugged in my USB hub where I had my mouse and keyboard plugged in so that I could control the device. I then performed a Factory Reset. At that point if I’m using scrcpy, the connection drops as the device is doing whatever it’s doing - however, since I had a monitor hooked up to the HDMI output I was able to see the “Erasing” graphic and the Control Hub took about twice as long as normal to boot, but it eventually booted up and launched the RC app that was previously installed so I’m not sure what it erased. But, maybe try uninstalling the app, doing a factory reset, and letting the device reboot, and then reinstall the app? I don’t know if there’s a filesystem integrity check that goes on, but we can cross our fingers and hope?

I wish I had a better answer, at this point all I know is that something went bonkers. I’d recommend seeing what a factory reset (after manually uninstalling the RC app) does for you. Use a different USB cable and force the REV Hardware Client to re-download the apps it has, and try installing the software again (I would reinstall the Control Hub OS too).

Crossing my fingers for you.


I didn’t have time to try this earlier, and I decided to move onto getting plan B (android device + expansion hub) ready for competition, but I THINK IT WORKED! I ended up deleting the RC app, factory resetting it, deleting the RC app again then re-installing everything. Then I was able to backup the code files from a restore. I will keep you updated as to whether we run into any related problems in the future but right now things look GOOD!


1 Like